PostgreSQL版:

lo_compat_privileges

PostgreSQL9.0之前,大对象没有访问权限,因此,总是被所有用户可读可写。 设置这个变量到on禁用新权限检查,为了兼容先前版本。 缺省是off。只要超级用户可以改变此设置。

设置这些变量不会禁用所有与大对象相关的安全检查—仅仅是在PostgreSQL 9.0 已经改变了的缺省操作。比如,lo_import()lo_export() 不管这些设置都需要超级用户权限。

条评论