PostgreSQL版:

lo_compat_privileges

PostgreSQL 9.0之前的版本中,大对象没有连接权限,并且对所有用户都是可读可写的。 将这个变量设置为on,从而禁用新的权限检查,以与以前的版本兼容。 默认是off。 只有超级用户可以更改这个设置。

设置这个参数不会禁用所有与大对象相关的安全检查 — 除了那些在PostgreSQL 9.0中已经修改了的默认行为。例如,lo_import()lo_export()需要超级用户权限而不管这个设置。

条评论