Toggle navigation
タイプ: enum
デフォルト: TLSv1
コンテキスト: sighup
再起動: false
値: [TLSv1, TLSv1.1, TLSv1.2, TLSv1.3]
以来: 12

使用するSSL/TLSプロトコルバージョンの最小値を設定します。今の所使用できる値はTLSv1TLSv1.1TLSv1.2TLSv1.3です。古いバージョンのOpenSSLライブラリはすべての値をサポートしません。サポートしていない値が設定されるとエラーが発生します。プロトコルバージョンTLS 1.0、すなわちSSLバージョン2あるいは3は常に無効となります。

デフォルトはTLSv1で、主に古いバージョンのOpenSSLライブラリをサポートするためです。すべてのソフトウェアコンポーネントが新しいバージョンのプロトコルをサポートしているなら、より高い値にするのが良いでしょう。

件のコメント